Visit our Coronavirus website for all COVID-19 information and resources.

CaTS | Information Technology

MacOS Big Sur Now Available

Please disregard if you are a Windows PC user

Wright State Faculty and Staff macOS users,

CaTS has completed compatibility testing with MacOS 11 Big Sur, and the upgrade is now available for university-managed Mac computers.

Devices Running MacOS Catalina or Newer

Please note that in order to upgrade your Mac to Big Sur using Self Service, your device must meet three prerequisites.

  • Your current macOS must be 10.15 (Catalina) or newer. (To check, click the Apple icon on the top left and choose About This Mac)
  • You must have the latest version of SentinelOne (campus-supported malware detection) installed.
  • You must be physically connected to the Wright State network, or connected to the VPN.

If you do not have the latest version of SentinelOne, you will see that upgrade available in Self Service and MUST complete this before you can see the Big Sur upgrade.

For more information on Self Service visit: https://www.wright.edu/information-technology/casper-self-service-software-installation-for-macs  

Devices Running MacOS Mojave or Older

If your macOS is earlier than 10.15 (Catalina), CaTS will need to manually upgrade your device. CaTS will be reaching out to users to schedule this upgrade individually.  If you would like to be upgraded sooner, please contact the Help Desk to schedule an appointment.

We would like to thank you for your patience during the additional compatibility testing that we had to complete regarding some key security software. CaTS has targeted the completion of Monterey compatibility testing and release to users during the second quarter of 2022.

If you have any questions, please contact the CaTS Help Desk at 937-775-4827 or email helpdesk@wright.edu