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1.0 Introduction 

Course Description 
With Adobe Dreamweaver CS4, you can easily add content to an existing website, including viewing, 

editing, creating, and publishing pages. This workshop will cover topics such as managing the site, 

formatting text, inserting tables and images, working with links, and customizing your Dreamweaver 

work environment.  

Target Audience 
This workshop is for faculty, staff and students who update or create university websites, not including 

their personal sites, and wish to familiarize themselves with the basic techniques used for creating and 

maintaining websites using Dreamweaver CS4.   

2.0 Dreamweaver Environment 

Dreamweaver Workspace 
The workspace is broken down into the following categories: 

 The Panel Groups (red box) contain a variety of panel groups based on their functionality, such 

as managing files, editing html tags, adding dynamic content to pages and adding design 

elements to pages.   

 The Document Toolbar (orange box) contains options that help the user perform tasks such as 

switching between different views and checking web pages for accessibility standards.   

 The Status Bar (blue box) displays quick links to various page elements.   

 The Property Inspector (green box) contains options for modifying various objects, such as text 

and graphics, placed on a web page.  The options in this panel will vary depending on the items 

selected. 

 The Document Window (black box) is where users will spend most of their time in 

Dreamweaver. The Document window is where the users enter (or paste copied) texts, insert 

images, design your page, apply formatting and insert forms. 
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Document Views 
Dreamweaver allows users to work on a web page in three different views called Design, Code and Split 

views.   

 The Design view displays a page the way it appears on the web browser.   

 The Code view displays the code used to create the page.   

 The Split view displays both the design and code of the page in a single window.  These views 

are located in the Document Toolbar. 
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3.0 Customizing the Workspace 
You can think of workspace as creating your own personal view of Dreamweaver.  When using 

workspaces, you can use the built-in workspaces or create your own based upon your needs and 

preferences.  To create your own workspace, manipulate the panels and toolbars to your liking.  For 

Example: 

Panel Customization 
You can float the various panels by dragging them onto the page.  In the Panels Group you can collapse 

all the panels to icons by clicking the two arrows to the right at the top of the panel group.   

Classic ‘Dreamweaver CS3’ Workspace 
If you really like the look of Dreamweaver CS3, you can choose the CS3 (classic) workspace that is 

automatically installed with Dreamweaver CS4.  To choose that workspace you go to Window > 

Workspace Layout > Classic.   

Saving a Workspace 
To save your custom workspace, go to Window > Workspace Layout > New Workspace.  By saving your 

workspace you will be able to easily access it at the top of the workspace list for quick reference at a 

later time.  

Reset a Workspace 
In case of a accidental or unwanted changes to a workspace, you can reset the worksapce by going to 

Window > Workspace Layout > Reset ‘Workspaces Name.’ 

Managing Workspaces 
To rename or delete the custom workspaces you have created, go to Window > Workspace Layout > 

Manage Workspaces.  

Changing Workspaces 
If at any time you would like to change workspaces, you can easily do so by clicking the drop down next 

to the search in the upper right hand corner and choosing your desired workspace environment.  

Alternatively you could go to Window > Workspace Layout. 

 

To better utilize the Dreamweaver workspaces, examine how you use Dreamweaver and what panels 

you continually open and close.  This will help you develop a Dreamweaver workspace that suits your 

needs so that you can perform tasks more effectively. 
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4.0 Creating a Website 

Site Definition 
Defining a site should be one of your first steps when taking on a new project.  Users can setup 

connections to their websites in a variety of ways.  We have focused on setting up the connection as a 

FTP & RDS Server for this workshop.  A FTP and RDS connection is a live connection where you can edit 

the files directly from the server.  To do this you will go to Site > Manage Sites.  Once the Manage Sites 

dialog box pops-up you will select New > FTP & RDS Server.  When the Configure Server dialog box 

opens, you will need to fill out the following: 

1) Name: used for description purposes only  

2) FTP host: for Departmental websites 

it will be www.wright.edu; for 

personal web spaces it will be 

unixapps1.wright.edu 

3) Host Directory: for Departmental 

websites this was provided to you in 

the email that was sent to you when 

you were granted access rights; you 

can leave it blank if you are setting up 

a connection to your personal web 

space 

4) Login and Password: this is your 

campus account login credentials 

(same as Wings) 

5) Use Secure FTP (SFTP): checkbox will 

need to be checked 

To verify the settings are correct, you will want to click on the Test button.  If the settings are correct 

you will receive the following message: ά5ǊŜŀƳǿŜŀǾŜǊ ŎƻƴƴŜŎǘŜŘ ǘƻ ȅƻǳǊ ǎŜǊǾŜǊ ǎǳŎŎŜǎǎŦǳƭƭȅΦέ  If the 

settings are incorrect, you will receive a message that an FTP error occurred, and you will then need to 

go back and modify the information.  Once all the data is entered successfully, you will then click the OK 

button.  

Once the connection is established you will then see the files on the server appear under the Files Panel, 

which is in the lower right hand corner of the screen.  If you manage multiple websites, you can easily 

switch between the sites by using the drop down menu in the files panel to the left of the Manage Sites 

link.  You are now ready to begin editing your pages.   

 

http://www.wright.edu/
unixapps1.wright.edu
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Create a Web Page 
For informational purposes you can create new pages by going to File >New.  However, for this 

workshop we will be editing pre-existing web pages.   

1) Find the page you want to edit by searching the directory under the Files Panel.   

2) Right-click on the file and choose Edit > Duplicate.   

a. Alternatively, you can highlight the file you want to edit and hit Control+D on the 

keyboard.  This will create a copy of that file in the same directory (ex. If your file was 

labeled staff.html the file that will be created is Copy of staff.html).   

3) Open the copied file by either double-clicking or right-clicking on the file and choosing open.   

a. You may receive a Dependent Files dialog box which asks if you want to get dependant 

files.  You will want to say No to this message.   

4) Now, make your changes in this file because if you get undesirable results, your users will not 

see them when they navigate to your site. 

 

 

Uploading Files to Server 

There may be times where you may want to insert new images or documents that are not on the server.  

Before you can insert them into your pages, you first need to upload those files into your web directory.  

The following instructions will allow you to upload files to the server.  

1) Download and Install SSH (https://www.wright.edu/cats/cw/software.html). 

2) Once installed, locate the SSH Secure File Transfer Client icon that looks like a folder.  

3) Once the application opens, click on Profiles -> Add Profile, enter a name (ex. Cricket) and click 

Add to Profiles. 

4) Bring up the edit profiles dialog box: 

a. Click on Profiles > Edit Profiles. 

b. Make sure your connection name is highlighted (ex. Cricket); in the Host Name field 

enter www.wright.edu. 

c. In the User Name field enter in your campus username (ex. w123abc) and click OK. 

5) Connect to the profile: 

a. Click on Profiles > Connection Name (ex. Cricket). 

https://www.wright.edu/cats/cw/software.html
http://www.wright.edu/
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b. Say No to the message about storing your key, in the password field enter in your 

password, click OK, and then click OK at the authentication response message. 

6) Once you have connected successfully, you should see the folder to the web directory on the 

right hand side (ex. Cricket) and the local machine directory on the left hand side. 

7) In the right pane, navigate to the folder where you will be placing the items. 

8) In the left pane, navigate to your files you wish to upload, click and drag to the right pane. 

 

Format a Web Page 
If you have an existing page or even if you create a new page, you may want to enhance its appearance.  

The Page Properties and Text Properties will be able to accommodate your needs.   

Page Properties 

The Page Properties dialog box is used to modify the settings for an entire web page.  Using this dialog 

box you can change the following: font style, font size, text color, background color, page margins, 

display of links and page title.  To open the Page Properties you will want to go to Format > Page 

Properties.   

Text Properties 

The appearance of text on the web page is controlled by the properties of the text such as its font type, 

size, color, paragraph format, alignment, style, and indenting.  To change these settings, you will want to 

highlight the text you want to edit and then go to the Property Inspector window. 
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5.0 Adding Design Elements 

Inserting Images 
So far you have created and formatted a web page. A web page that contains only textual content may 

seem boring to the users resulting in them leaving your site, so you may want to make it more appealing 

by inserting some images.   

To insert an image on a page: 

1) Click in the desired location to place the picture. 

2) Choose Insert > Image. 

a. You can also find this in the Insert panel on the Common tab by clicking the Images 

button and selecting Image.   

b. You can also have your cursor where you want the picture to appear.  In the Assets 

Panel, locate and click the picture and then click insert at the bottom of the Assets 

panel.  

3) Navigate to the desired folder, select the file, and click OK. 

4) In the Image Tag Accessibility Attributes dialog box, in the Alternate Text text box, type an 

alternate name describing the image and click OK. 

5) You can then specify the image properties by utilizing the Property Inspector. 

 

 

The graphic above displays the property inspector for images. 
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Inserting Tables 
{ƻƳŜǘƛƳŜǎ ǿƘŜƴ ōǳƛƭŘƛƴƎ ǿŜō ǇŀƎŜǎ ƛǘΩǎ ŘƛŦŦƛŎǳƭǘ ǘƻ ǇƭŀŎŜ ŜƭŜƳŜƴǘǎ ƻƴ ǘƘŜ ǇŀƎŜ ǿƘŜǊŜ ȅƻǳ ǿŀƴǘ ǘƘŜƳΦ  

By using tables, you will be able to position the elements more precisely on the page. 

To create a table on a page: 

1) Place the insertion point at the desired location on the web page. 

2) Choose Insert > Table. 

a. You can also find this in the Insert panel on the Common tab and clicking the Table 

button. 

3) Specify the desired settings and click OK. 

4) You can then specify the table properties by utilizing the Property Inspector. 

Tip: If you are in the last cell of the table, you can press Tab to add a new row. 

 

 

The graphic above displays the property inspector for tables. 
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Working with Links 
You can have hyperlinks, email links and anchor links on your page.  In web terms, a hyperlink is a 

reference (an address) to a resource on the web.  Hyperlinks can point to any resource on the web: an 

HTML page, an image, a sound file, a movie, etc.  An email link is a link that will open up the individuals 

default email client and fill in the email address field.  An anchor is a term used to define a hyperlink 

destination inside a page.  Using these various links can make your website user-friendly. 

Hyperlinks 

Hyperlinks are links that reference another web page on the same website or a different website.  By 

default, the text that contains a hyperlink is shown in blue and is underlined.  When you click a 

hyperlink, the target web page, by default, opens in the same window.  It can also be opened in a new 

window.  Hyperlinks can also be created on text or images. 

To create hyperlinks: 

1) Select the desired text or image. 

2) Choose Insert > Hyperlink. 

a. You can also find this in the Insert panel on the Common tab and clicking the Hyperlink 

button. 

3) You can now either edit the properties in the Property Inspector by clicking OK or you can fill the 

information in the dialog box. 

a. Options 

i. Text: Allows you to specify the text to which you want to create a link. 

ii. Link: Allows you to specify the web page to which you want to link. 

iii. Target: Defines where the linked document will be opened. 

iv. Title: Allows you to type a description of the page that you are linking. 

v. Access Key: Allows you to specify a shortcut key to select the link. 

vi. Tab Index: Allows you to specify the tab order. 
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Email Links 

Having a link that allows visitors to send email from your website could be a great addition to your site, 

making it easy for your visitors to send questions or comments.  On the other hand, it does have its 

flaws.  One issue is that it opens up the email address to spammers who can scan websites for email 

addresses to send out junk email appearing to come from you.  Another issue is that if individuals do not 

have a mail client setup on their computer, it will take them through a tutorial to setup their mail using 

programs like Outlook or Windows Mail.  The best viable option would be to include a form on your 

website so they can contact you. 

To create an email link: 

1) Select the desired text or image: 

2) Choose Insert > Email Link. 

a. You can also find this in the Insert panel on the Common tab and clicking the Email Link 

button 

3) In the email text box, type the desired email address and click OK. 

 

Anchor Links 

If you have an exhaustive amount of information on a page you may want to include anchor links.  

Anchor links allow you to link to a particular section on the current page.  By having anchor links you 

enable the users to navigate directly to the information they are interested in.  You could utilize anchor 

links when you are displaying frequently asked questions. 

To create anchor links: 

1) Place the insertion point before the text for which you want to create an anchor. 

2) Open the Named Anchor dialog box. 

a. Insert > Named Anchor 

a. Or, you can also find this in the Insert panel on the Common tab and clicking the Named 

Anchor button 

3) In the Anchor name text box, type a name and click OK to create the anchor. 

4) Select the text to which you want to link the anchor. 
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5) There are three ways to create a link to the named anchor: 

a. In the Property Inspector, in the Link text box, click and type # followed by the anchor 

name to create a link to the named anchor (ex. #name). 

b. Or, in the Property Inspector, to the right of the Link text box, click the Point to File 

button and drag it to the anchor marker on the web page. 

c. Or, create a link using the Hyperlink dialog box. 

i. In the Link text box, click and type # followed by the anchor name (ex. #name). 

ii. Or, from the Link drop-down list, select the desired anchor. 

 

   Links to Anchors 

   Named Anchor 
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6.0 Publishing Pages 
To submit your changes, go to File > Save to Remote Server.  A Save File dialog box will appear, navigate 

to your original file (ex. staff.html), single click on the file and choose Save.  A confirmation dialog box 

will appear stating, ά! ŦƛƭŜ ǿƛǘƘ ǘƘŀǘ ƴŀƳŜ ŀƭǊŜŀŘȅ ŜȄƛǎǘǎΦ  ²ƻǳƭŘ ȅƻǳ ƭƛƪŜ ǘƻ ǊŜǇƭŀŎŜ ǘƘŜ ŦƛƭŜΚέ Click Yes 

and delete the copied file. 

7.0 Miscellaneous 

Dreamweaver Tips  
 In Dreamweaver CS4 they went with a gray color of various icons and text to lessen the 

distraction of the web developer.  If you prefer colored icons like in previous versions of 

Dreamweaver, you can go to View > Color Icons.   

 To enter a single line break instead of a paragraph break, you will press Shift + Enter. 

 If you have word documents and you would like to import it into Dreamweaver, all you need to 

do is upload the file onto the server and then in Files panel locate the file and drag and drop on 

to your page. 

 If you want to get the most out of your screen by hiding the panel group and properties 

inspector, pressing F4 on the keyboard will hide them.  If you quickly want to access those 

panels again, all you have to do is move your cursor over the gray bar where those panels 

should be.  To exit out of that mode you just need to press F4 again. 

Web Developer Tips 

Frames 

Overall frames are a bad idea and should be avoided.  A few of the reasons why frames should be 

avoided are listed below: 

1) Browsers: Some web browsers do not support frames 

2) Bookmarks: Users can't bookmark individual pages of your site, as only the URL of the original 

frameset shows up in the browser. Thus, somebody who finds something interesting buried 

deeply within a framed site might have trouble getting back to it later. 

3) Search Engines: Since many search engine robots still don't index frames, a framed site may be 

cutting off most of its content from the indexers. 

4) Printing Issues: Visitors need to take further steps within their print settings to ensure the 

information they want is printed correctly. In most cases, a full page cannot be printed as 

displayed on the screen, only in sections corresponding to the frame. 
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5) Scroll Bars: Scroll bars, divider bars. If your framed site uses a number of frames, scroll bars can 

prove to be unsightly. 

6) External Linkage: If other sites wish to link to specific pages in your site, it is more difficult for 

them to do so. 

7) Navigation. You have to have everything just right when you are using frames. If you don't 

specify the frames correctly, when you click on a link it can come up in the wrong window, thus 

eliminating your navigation panel.  Therefore, the person is trapped on your site, in your frames, 

with nowhere to go. 

Naming Convention  

Deciding what to name your web files and folders can be an important part of creating a cohesive Web 

site.   Here are some things to avoid when naming files or folders for web use:  

 Spaces (http://www.wsu.edu/my  file.html) 

 Periods (dots) that do not immediately precede a file extension 

(http://www.wright.edu/my.folder/my.file.html) 

 Any character that is not a letter, a number, a dash, or an underscore 

(http://www.wright.edu.edu/my*site's#graphics/great!photo.gif) 

Also, when linking, use the same capitalization scheme as the files.  Inconsistency could result in broken 

links.  If you are posting newsletters or other periodicals it is best to organize your files numerically from 

the larger to smaller time unit (e.g., year, month, day). Compare the following filenames, organized 

alphabetically: 

April2003.pdf 200304.pdf 

April2004.pdf 200404.pdf 

August2003.pdf 200308.pdf 

Feb2004.pdf 200402.pdf 

The files in the right column will always sort in chronological order where the left column will not.  This 

makes it much easier to find a specific edition or range of editions when you are performing site 

maintenance. It is also a much easier system to use consistently. 

 

http://www.wright.edu.edu/my*site's#graphics/great!photo.gif

